pygame is
Simple DirectMedia Layer is
Site Swing



The information below should apply equally well for Python 2.4 and 2.5. For Python 2.3 or earlier, you use Visual Studio 6 (although pygame source no longer compiles under it).

If you don't have the toolkit compiler installed, you can download it here.

If you don't have your system configured to build python extensions with the toolkit compiler yet, you can follow the directions here.

For pygame dependencies, you can use the prebuilts from the downloads page, but you may want to replace the sdl dll's with the ones here, because the ones on the download page link to a different c-runtime so all the load xxx from file functions crash. If you want to build the dependencies yourself, you can find instructions here.

Finally to build, you want to run a batch file to set the path and environment variables for the toolkit (see the second link above), then run "python" followed by "python --build"

If you have problems, try asking on the mailing list, or if you fix them yourself, update this page with the solution


our projects welcomes all python game, art, music, sound, video and multimedia projects. If they use pygame or not.
recent releases
Oct 1, 2015

Sep 11, 2015

Sep 6, 2015

Aug 26, 2015

Aug 25, 2015

Aug 21, 2015

Aug 16, 2015

Jul 30, 2015

Jun 24, 2015

... more!
for pygame related questions, comments, and suggestions, please see help (lists, irc)