Skip to main content

Map Editor - 0.1.0

Map Editor is a tile-based map maker primarily targeted for 2D games. It's made with Tkinter in Python and is meant to be language and library agnostic. It currently supports tiles up to 256 px. on rectangular maps of arbitrary size.


Westley Marti­nez
(anikom15)

Map Editor is designed to be mostly language and library agnostic. The maps are saved as JSON data and do not contain any actual image data. Image loading is left to the developer to do as they see fit.

Note that this program should be considered alpha. Features may be added or removed and the API may change significantly in the future.

Features:

  • Maps are built up out of square tiles sizeable up to 256 px.
  • Changeable viewport for working with multiple resolutions
  • 'Blank' tiles
  • Multiple maps can be opened and edited at the same time
  • Support for sprite sheets

Visit the website for more information.

Links

Home Page
https://bitbucket.org/anikom15/map-editor/overview
Source
https://bitbucket.org/anikom15/map-editor/downloads

Releases

Map Editor 0.1.0 — 16 Nov, 2013

Map Editor 0.1.1 — 17 Nov, 2013

Map Editor 0.1.3 — 19 Nov, 2013

Map Editor 0.1.2 — 19 Nov, 2013

Pygame.org account Comments

  • Tregavin 2013-11-30 20:40:54

    I was wondering if there would be any support for 2.xx python software? it seems i get an error that I don't have the module tkinter. I believe it may be a problem simply with compatibility from 2.xx and 3.xx but I would like to know your thoughts, this project looks very interesting

    Matthew Mirvish 2013-12-12 22:16:00

    simply change all tkinter to Tkinter

  • Westley Mart√≠nez 2013-12-01 23:59:24

    Yes it only works with Python 3.x. The editor will not be backported to Python 2 since the map format is language agnostic. However, the library for using maps (animap.py) may be (for use in games written in 2.7). I haven't tested it, but it is probably trivial to backport animap.py. If I decide to do that, it will most likely be in version 0.2, which will include a number of new features for the editor and a new API.

    If you would like to use the maps in Python 2.x immediately, you should install Python 3 with Tk to get the map editor to work, design your maps (and report any bugs you find) and then try to modify animap.py to work Python 2. Feel free to message me for help.