Skip to main content

Pyjsdl

Python-to-JavaScript Multimedia Framework


jggatc
(jggatc)

Pyjsdl is an implementation of Pygame using JavaScript API including HTML5 canvas. The development objective of the module is to permit applications coded in Python and Pygame to compile into JavaScript using the Pyjs compiler and execute in the Web browser. Further development should provide enhanced functionality and performance.

Git repository: https://github.com/jggatc/pyjsdl/

Released under the MIT License.

Links

Home Page
http://gatc.ca/projects/pyjsdl/

Releases

Pyjsdl 0.19 — 21 Aug, 2014

Pyjsdl 0.18 — 15 Mar, 2014

Pyjsdl 0.20 — 11 Nov, 2014

Pyjsdl 0.21 — 13 Apr, 2015

Pygame.org account Comments

  • Peter 2014-08-05 17:41:48

    I'm having trouble getting this to install properly. I'm using pip.

    Jim 2014-08-06 23:14:48

    Did pip installation of pyjs on linux - had an issue with the dependency 'six' that was solved by adding the --upgrade flag to the pip install command. Hope this helps...

  • jmm0 2014-10-01 18:05:10

    Have you considered adding sound support? René has a JavaScript project for playing audio using HTML5 that might help. http://rene.f0o.com/~rene/shit...

    Jim 2014-10-02 05:23:09

    Started coding sound support. Was implementing using an available library, which should be sufficient but will check the library you suggested. Had hoped to include this feature already, but was preoccupied with code optimization.

    Still considering other cross-platform JavaScript audio libraries with low level API.

    Jim 2014-10-06 03:49:19

    Updated Pyjsdl with sound support, at the moment only included in the current Git development version linked off the project page. The mixer module is not fully completed but appeared to function properly. Implemented in HTML5 audio, but may decide to use a cross-platform JavaScript audio library to include use of the newer Web Audio API.

    jmm0 2014-10-09 20:30:34

    Great! Thanks!

  • AVeryGoodUsername 2016-02-28 02:39:17

    I get this error:
    Could not find any downloads that satisfy the requirement pyjsdl
    while trying :
    sudo pip install --upgrade pyjsdl

    Can you please help? :c

    Jim 2016-02-29 21:53:49

    Currently not distributed via pip install, download Pyjsdl from the project page or Git repository, then unpack in or on path of your Python app folder.

  • Vetta 2016-06-21 04:21:08

    Funny bug in ver.0.21: for draw.arc if the rect argument is not squaire (length not equal to height), color of the arc will always be black.

    Jim 2016-06-22 17:52:22

    Revised draw.arc method on pyjsdl git site. Thanks.

  • Asher Wolfstein 2017-06-27 16:37:49.632630

    It requires a bit of reprogramming, but i made a pygame library "port" to the browser/nodewebkit using Brython and GameJS. You can program using a version of pygame and python 3 in the browser. You can check it out at https://github.com/asherwunk/pygjs